iPhone 2.0.1 on 1G iPhone

Tried to update my first generation iPhone to the new firmware 2.0.1. Didn’t work out so well…

Anyone know what an error (-19) is? Frustrating indeed.

UPDATE:
Seems to be that restoring the iPhone to 2.0 and then doing the 2.0.1 update works.  A step you should not have to take but a solution none-the-less.  Now to make this one a pay-as-you-go phone…  Should I pwnage jailbreak it and put it on t-mobile?  Do they have better no-contract plans?

UPDATE:
Can’t seem to get it to jailbreak.  Ideas?  I was using PwnageTool 2.0.2, said it failed.  I guess I need to know where the iPhone 2.0.1 firmware is on my computer and I need the bootloader files… which I don’t have and can’t find.  Hmmm, is T-Mobile’s network even worth the work or should I just GoPhone it?

Zemanta Pixie